Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
++ TLS 1.2 Service startet nicht ++
#1
Guten Morgen,

www.ssllabs.com stuft uns Aufgrund TLS 1.0/1.1 auf Grad B ein. Setzte ich den No Spam Proxy Server per IISCrypto auf nur TLS 1.2, startet "NetatworkMailGatewayGatewayRole" und "NetatworkMailGatewayIntranetRole" nicht mehr.

Ist das ein Bekanntes Problem und wie kann ich den NSP nur mit TLS 1.2 nutzen?

Finden konnnte ich nur: "Intranet role cannot communicate with WebPortal with TLS 1.2 only"
https://www.nospamproxy.de/de/knowledge-base/release-notes-nospamproxy-13-0-regularer-kanal-regular-channel/

Freundliche Grüße
JD
Zitieren
#2
Guten Morgen JD,

ich habe einmal versucht das Problem zu reproduzieren, bei mir klappt alles :/
Im Anhang sind meine IIS Crypto Einstellungen zu sehen.
Intranet Rolle und Gateway Rolle laufen hier auf einem System und nutzen eine lokale SQL Express Installation.

Wie ist es bei dir aufgebaut?
Welche NSP Version hast du im Einsatz und welche SQL Version?


Grüße,
Jan


Angehängte Dateien Thumbnail(s)
   
Zitieren
#3
Guten Morgen Jan,

ich habe mir vorerst das aktuellste IISCrypto geladen und die Einstellungen wie bei Dir gesetzt und einen Neustart durchgeführt. 
Leider kommt dann der "NSP Intranetrolle" Dienst nicht mehr.

Grüße
Jens


Angehängte Dateien Thumbnail(s)
           
Zitieren
#4
Hallo Jens,

Werden dir noch weitere Details angezeigt wenn du auf eine der Meldungen klickst?
Diese sollten dann im unteren Bereich des Fensters mit der Fehlermeldung auftreten.

Alternativ schau einmal in die Ereignisanzeige, da sollte direkt die komplette Meldung zu finden sein.

Gruß
Jan
Zitieren
#5
Hallo Jan,

ich habe den Fehlertext in die Zwischenablage kopiert und als txt angehängt.

Grüße
Jens


Angehängte Dateien
.txt   1.txt (Größe: 12,84 KB / Downloads: 2)
Zitieren
#6
Hallo Jens,

kannst du bitte einmal gucken ob der Dienst "NetatworkMailGatewayManagementService" läuft?
Guck zusätzlich einmal mittels netstat -na nach ob es einen Listener gibt der auf 6060 lauscht. 


Gruß
Jan
Zitieren
#7
Hallo Jan,

exakt diesen Dienst sehe ich nicht. Alle Dienste außer "NoSpamProxy - Intranet Role" laufen, stellt man auf nur TLS 1.2 um.
Port 6060 hört. Diensteübersicht, netstat -na und Meldungen nachdem nur TLS 1.2 aktiv ist, siehe Anhang.

Ereignis zeigt dann "
ID 36888"

"Es wurde eine schwerwiegende Warnung generiert und an den Remoteendpunkt gesendet. Dies kann dazu führen, dass die Verbindung beendet wird. Die schwerwiegende Warnung hat folgenden für das TLS-Protokoll definierten Code: 70. Der Windows-SChannel-Fehlerstatus lautet: 105."


Grüße
Jens


Angehängte Dateien Thumbnail(s)
           
Zitieren
#8
Hallo Jens,

sieht soweit erstmal alles gut aus.
Beim Service Namen habe ich leider nicht aufgepasst "NetatworkMailGatewayManagementService" ist das gleiche wie "NoSpamProxy Management Service" und der läuft.

Das lässt meine Vermutung wieder auf den SQL Server zurück fallen.
Schau bitte einmal nach der genauen SQL Server Version, Microsoft hat da ein paar Voraussetzungen für TLS 1.2 only:
https://support.microsoft.com/de-de/help...sql-server

LG
Jan
Zitieren
#9
Ich mische mich mal kurz mit ein: Aus Erfahrung würde ich mit IISCrypto erstmal wieder den System-Standard wieder herstellen. Das ist ebenfalls eine Option bei der Auswahl. Mit dieser Auswahl muss TLS 1.2 auf jeden Fall funktionieren.
Gruß Stefan
Zitieren
#10
Hallo Jan,

nach Update des SQL 2012 auf 2014 und danach auf 2017, klappt es nun.
Danke für den Hinweis.

Grüße
Jens
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste